You need to have the latest version of Flash player installed to play the game, thx.